Help with hour zero


#1

If I want my lights to turn on at 4pm and turn off at 10am what should the hour zero be set to?i don’t understand how to set my light cycle it keeps giving me errors


#2

To get the grow day cross over the calendar day, you need to use Hour-Zero to shift the time zone.

Let’s say you keep the Hour Zero at 12am (normal time).

(Hour-Zero Setting is here: appliance main screen, click settings icon on the top right, select “system settings”, Hour-Zero: at 12:00am.)

Then you change the grow plan’s day light to 4am-10pm.
(Grow plan is here: appliance main screen, click settings icon on the top right, select “grow plan”, and select a stage and change time range accordingly)

Then you go to the settings to change Hour Zero to be 12PM. It will flip the day and night and new time range is 4pm -10am :slight_smile:


#3

Thanks my friend


#4

So with zero clock set to 12pm is that eastern time or pacific time I’m still trying to figure out the light time feature


#5

How do I know what time the app thinks it is?


#6

Very good question. haha. It is the time difference between your phone and the AeroKit.

12:00am = 0 hours difference
1:00am = 1 hour difference (5am -> 6am)
2:00 am = 2 hour difference (5am ->7am)

12:00 am = 12 hour difference (5am -> 5pm)

Try to switch the HourZero and see the grow schedule time change.

say if you want to make change of 7am - 7pm schedule to 4pm -4am, you need to make HourZero of 9am ( difference betwee 7am - 4pm in hours). Try - / + to make it to 9am. If - doesn’t work, try +. It will cycle back.

I know it is a pain. Will do away with this concept in the future.


#7

if I’m on the east coast and I want a 18 hour veg cycle I want my light to turn on at 4pm and turn off at 10am what should the zero hour be maybe then I will understand I can’t seem to figure it out for the life of me.


#8

Ok. Here is what I would do. Set the HourZero to be 12:00am first (default).

Change the grow plan to be 4am - 10pm.

Change HourZero 12:00pm

Then verify the light schedule should be 4pm - 10am.


#9

I did that and light doesn’t come on at 4


#10

That would be frustrating. Can you post a screenshot of the grow plan screen and HourZero screen. Let me see if something different.


#11

This is how it’s set and light will still not turn on at desired time but it will turn on off in maintenance mode and I believe it will still turn on at a different time


#12


#13

Could you do a reboot of the controller. (unplug 24DC power cord and wait 3 seconds and plug back in )

And see if the light will be on after boot (20 seconds)


#14

Yes I will do that and also when I change it this way if I go back into plan to adjust spray nozzles or root temp it tells me error because of zero hour


#15

Light is still not on


#16

Light plugs into ribbon b purple white correct?


#17

Got you. The “Invalid Time Range” error appears when users trying to make changes to grow plan when it is not in the HourZero setting. It is a bug needed to be fixed.

I will check on the scheduling on time schedule part. It is strange. Works for me. Might take sometime for that. Get back to you tomorrow.


#18

If the manual testing is ok, the wiring should be right.

Ok. I found a little bug in the “Time shifting” function (HourZero concept).

v2.06 requires reload grow plan or restart controller to take effect.

I just upload v2.08, you can upgrade to that and it should control the light without reload grow plan or reboot the controller. (you need to refresh the main screen to see the light status though. The mobile app updates needs approval by Apple. )

The mobile app update will also address the issue of “Invalid Time Range” warning message. Should be ready in the coming days after Apple approval. For now, you have to change the HourZero to default make changes and switch back to desired timezone.


#19

So I reload grow plan until app update is released?


#20

AeroKit’s firmware 2.08 has been released.

On the appliance list page, swipe the appliance to the left and select “OS” download icon. And follow the screen to upgrade to 2.08. This fix allows HourZero change without reboot.